Originally Published: Saturday, 19 August 2000 Author: Terry Warner
Published to: news_enhance_games/Games News Page: 1/1 - [Printable]

New DRI drivers

3Dfx's Joseph Kain sent out a new anncoument today releasing the new DRI drivers, that were used during Linux World Expo. Click on the topic for the full release info.

   Page 1 of 1  

There is a new XFree86 4.0.1 X Server/Mesa prereleases for Voodoo Banshee, Voodoo3, Voodoo4 and Voodoo5 available. These drivers should be used in conjunction with XFree86 4.0 and Glide 3 with DRI support (provided). These are the drivers that were used in the demonstrations at 3dfx's Linux World Expo booth. The ran games such as Quake3, Unreal Tournament (with OpenGL renderer), Soldier of Fortune and others. Note these drivers will still not work with, Myth2, Quake2 or other Glide and Mesa2x based applications but, the the DGA mouse bug been has been fixed. Also note, these drivers are still in early development. At this time only a single chip on the board is supported, that means that the board will not run at its full speed potential, nor are Full Scene Antialiasing (FSAA) and T-Buffer Cinematic effects available. As development continues these features will be implemented in the drivers.

The files tdfx_dri-4.0.1-1.i386.rpm tdfx_drm-1.0-3.src.rpm Glide_V5-3.10-2.i386.rpm can be found here:   http://linux.3dfx.com/open_source/download/voodoo5_dri.htm

Voodoo Banshee/Voodoo3: The file tdfx_dri-4.0.00-3.i386.rpm can be found here:   http://linux.3dfx.com/open_source/download/voodoo3_banshee_dri.htm

Changes: - Based on XFree86 4.0.1 - DGA mouse support - No longer overwrites /etc/X11/XF86Config, however previous packages were setup to restore the saved backup of /etc/X11/XF86Config so you may want to backup the file manually before installing this package.

Please follow the instructions on the above pages to install these packages.

If you experience any difficulty installing any of these driver please direct your questions to the USENET newsgroup 3dfx.glide.linux.

Again note that this release does NOT work with Glide applications or Applications that are linked against older revisions of Mesa.





   Page 1 of 1